Version of Python 3 on containers downgraded unexpectedly
Incident Report for Glitch
Resolved
This incident has been resolved, all Python projects should be running on their intended version. We apologize for the trouble and thank you for your patience. As always, if you continue to run into issues, let us know by filing a ticket at help.glitch.com.
Posted Mar 27, 2024 - 11:18 EDT
Monitoring
We've deployed a fix and are starting to see some projects get the expected, correct version of Python. We are still monitoring the situation, and it can take up to 12 hours for all containers to get the update. We appreciate your patience as this fix rolls out.
Posted Mar 26, 2024 - 16:30 EDT
Update
We are still testing a fix to the Python degradation issue and will post an update when we plan to deploy any changes.
Posted Mar 26, 2024 - 10:13 EDT
Identified
We’ve identified the issue causing the degradation of the version of Python on containers. We need to do more testing of our solution to ensure we do not cause more issues, and we anticipate that fix going out tomorrow (Tuesday 3/25). We’ll keep you updated and appreciate the patience of our Python developers.
Posted Mar 25, 2024 - 15:53 EDT
Investigating
We're currently investigating an issue where the version of Python on containers had downgraded to 3.5. This only impacts projects running with Python instead of Node.
Posted Mar 25, 2024 - 10:00 EDT
This incident affected: Project Hosting.