Intermittent downtime occuring
Incident Report for Glitch
Resolved
The issue is now resolved.
Posted over 1 year ago. Mar 16, 2018 - 17:02 EDT
Investigating
we are experiencing short spurts of downtime and are currently investigating the issue.
Posted over 1 year ago. Mar 16, 2018 - 10:25 EDT