Slow project start and API response times
Incident Report for Glitch
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 14:50 EDT
Investigating
We are currently investigating this issue.
Posted Jun 16, 2020 - 11:25 EDT
This incident affected: API and Project Hosting.