System Migration: help.glitch.com

Incident Report for Glitch

Resolved

The new platform is online and serivce is restored. The team will be updating embedded links within content and other polish work on the site.
Posted Mar 03, 2025 - 18:13 EST

Identified

The vendor migration for the help.glitch.com documentation and helpdesk system is currently in progress. During this time, access to documentation and the ability to create tickets through the user interface may be temporarily unavailable.

Rest assured, all Glitch production systems remain unaffected, and you can still reach us via direct email at support@glitch.com.
Posted Mar 03, 2025 - 17:09 EST