glitch.com is loading intermittently
Incident Report for Glitch
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 18:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2020 - 06:00 EDT
Investigating
The glitch website is slowly loading or gets stuck loading. Our team is investigating this now.
Posted Jun 23, 2020 - 04:32 EDT
This incident affected: Editor and Community Site.