Projects loading slowly or not loading at all.
Incident Report for Glitch
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 11:56 EDT
Identified
We are continuing to work on a fix for this issue.
Posted Jun 24, 2020 - 11:56 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2020 - 09:50 EDT
Identified
Changes made to the Glitch infrastructure that are intended to improve stability of the site in the long term have had unintended and unexpected negative side effects that we have been observing since Wednesday, June 17.

These side effects include:
- Projects loading slowly
- Projects being stuck during an npm install
- Project sync issues
- Remixes not working

We are now:
- Undoing the infrastructure changes that caused project issues
- Creating a process to prevent existing projects from being immediately affected by future work we are doing to improve the overall stability of the site.
Posted Jun 22, 2020 - 13:48 EDT
Update
Hey there! No real news, but we wanted to let you know that we are still here working to stabilize the system, and we thank you for checking in with us. We know this has been a long one :(
Posted Jun 19, 2020 - 23:34 EDT
Update
While some projects are working as expected, we are continuing to investigate the following two issues:
1. Some projects are getting stuck in “waking up” mode then stop loading after 3 minutes, making the editor inaccessible.
2. Some projects are taking longer than usual to prepare / install node modules. During this time the editor is accessible, but the public-facing app side will not fully load.
Posted Jun 18, 2020 - 10:34 EDT
Update
We are continuing to investigate the root cause of this issue. In the meantime, project load time appears to be improving.
Posted Jun 17, 2020 - 18:59 EDT
Investigating
We are currently looking into why some projects are loading slowly or not loading at all for some users.
Posted Jun 17, 2020 - 16:30 EDT
This incident affected: Project Hosting and Editor.