Projects appear to be suspended for phishing
Incident Report for Glitch
Resolved
The issue has been resolved and the affected projects are up and running again.
Posted 2 months ago. Jun 12, 2019 - 08:23 EDT
Identified
A subset of projects appear to be suspended for phishing when they shouldn't be.
Posted 2 months ago. Jun 12, 2019 - 07:55 EDT
This incident affected: Project Hosting.