Support Forum down.
Incident Report for Glitch
Resolved
Posted Nov 19, 2019 - 14:37 EST
Investigating
Our support forum provider is currently experiencing some downtime. https://twitter.com/discourse/status/1196847961159983105
Posted Nov 19, 2019 - 12:57 EST
This incident affected: Support Forum.