Some projects experience slow start and placement times
Incident Report for Glitch
Resolved
This incident has been resolved.
Posted Jul 08, 2024 - 15:03 EDT
Investigating
We are currently investigating an issue that is causing some projects to have slow start times.
Posted Jul 08, 2024 - 11:55 EDT
This incident affected: Project Hosting.