glitch.com intermittent site outages
Incident Report for Glitch
Resolved
We have tracked down and fixed the cause of the intermittent outages; the site is back to normal.
Posted 4 months ago. Apr 19, 2019 - 05:23 EDT
Investigating
The glitch.com community site is experiencing intermittent outages. We are investigating.
Posted 4 months ago. Apr 19, 2019 - 05:02 EDT
This incident affected: Community Site.