Some experiencing inability to log in and slow loading times
Incident Report for Glitch
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 10:03 EDT
Investigating
We are currently investigating reports of issues with logging in via Google or magic link. We've seen some success with users clearing browser cache and trying again, or waiting several seconds after submitting credentials if there is a blank page.
Posted Mar 17, 2023 - 16:20 EDT
This incident affected: Community Site and API.