Puppeteer usage to be temporarily blocked while we manage an incident
Incident Report for Glitch
Resolved
We have removed our temporary ban on the Puppeteer npm dependency. Through mitigating the incident that got us here, we realized that having Chromium on containers has been more trouble than it's worth due to its abuse, which negatively impacts the service availability for the rest of the Glitch community. In short, the vast majority of Chromium usage on Glitch is not by legitimate projects, and the result of those projects running is a worse experience for everybody else.

Therefore, we will be removing Chromium from containers on Glitch on Monday, February 12 (one week from today). This unfortunately means that while Puppeteer will be initially installable, its need for Chromium on the file system will mean that it won’t be useful on Glitch. We know there are some apps that will be negatively impacted by this change, and we encourage you to share your feedback with us if your apps are affected, so we can help you find an alternate solution.

If your project has been suspended for using Puppeteer and you have not yet reached out, file a ticket at help.glitch.com with the project name and we will unsuspend it for you.
Posted Feb 05, 2024 - 14:11 EST
Identified
We're investigating an incident involving malicious use of the puppeteer package, it may lead to projects running puppeteer being suspended.
Posted Jan 30, 2024 - 13:00 EST
This incident affected: Project Hosting.