Glitch API and Project Hosting experiencing downtime or slowness
Incident Report for Glitch
Resolved
This incident has been resolved.
Posted Mar 20, 2020 - 15:37 EDT
Identified
We've identified an issue causing apps to load very slowly or not at all and a fix is being implemented.
Posted Mar 20, 2020 - 15:03 EDT
This incident affected: Project Hosting and API.