Glitch API and Project Hosting experiencing downtime or slowness
Incident Report for Glitch
Resolved
This incident has been resolved.
Posted Apr 10, 2020 - 10:09 EDT
Update
We are continuing to investigate this issue.
Posted Apr 10, 2020 - 09:52 EDT
Investigating
We are currently investigating this issue.
Posted Apr 10, 2020 - 09:42 EDT
This incident affected: API and Project Hosting.